Intermittent App Loading Issues

Incident Report for Calibrate's App Status Page

Resolved

Amazon has fully cleared their outage. Our systems remain stable.
Posted Oct 21, 2025 - 02:43 UTC

Monitoring

Amazon AWS has returned to a stable state, ensuring we are in a stable state. We will continue monitoring our systems to ensure app stability.
Posted Oct 20, 2025 - 19:55 UTC

Identified

The issue is related to Amazon server outages across the US. They have resolved many but not all of the failures. We will continue to monitor progress. For more info from Amazon, see their status page - https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 18:30 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:09 UTC

Investigating

We have received reports of intermittent app loading issues and are investigating.
Posted Oct 20, 2025 - 16:09 UTC
This incident affected: App Log-in.