Delayed Lab Orders and results
Incident Report for Calibrate's App Status Page
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 21:03 UTC
Identified
Due to the ongoing CrowdStrike outage - some labs in the United States are unable to receive orders or respond with results at this time. While our internal system is operating as usual, this may cause delays in lab orders or results for our members until the lab network systems are operational again. We will monitor and continue to update this page.
Posted Jul 19, 2024 - 18:22 UTC
This incident affected: Labs.